QTS Data Center - Network event

Incident Report for PTC Cloud Services

Resolved

Incident is marked as resolved.
Posted Aug 02, 2019 - 20:59 UTC

Monitoring

Infrastructure services impacted in the QTS Data Centre have been restored. Servers are up and functioning as expected, we are in the process of validating and closely monitoring workflows.
Posted Aug 02, 2019 - 20:12 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 02, 2019 - 20:10 UTC

Identified

PTC has identified an issue with a storage array impacting access to the servers.
We are working with our support vendors at highest priority to restore the services.
Posted Aug 02, 2019 - 20:05 UTC
This incident affected: AWS North America (Atlanta).